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Introduction to BusinessObjects 5i

BusinessObjects 5i is a fully integrated query, reporting and multi–dimensional data analysis tool. It enables users to access and analyse information in the University’s corporate database.  
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1 Preliminaries

Purpose

BusinessObjects is an integrated query, reporting and data analysis tool, which makes it easy for the user to access and report information in the University's corporate databases. This document is intended to provide an introduction to Version 5 of BusinessObjects — Version 5 replaces the previous version and provides increased functionality. 

Audience

This document is intended to meet the requirements of both new and existing users of BusinessObjects. Whilst, the document provides an overall introduction, some sections are specifically intended for existing users who are upgrading to Version 5.  

Prerequisites

BusinessObjects 5i is available only on the Managed Windows Service. This document assumes a working knowledge of Windows XP.

Further Information

The basic functions of BusinessObjects 5i are introduced in this document. For further discussion of advanced topics, this document will refer you to the on-line help available from the BusinessObjects Help menu. 

The BusinessObjects Help menu has a number of options and the available on-line help takes various forms:

· If you select the BusinessObjects Help option, a conventional help window pops up showing 3 tabs - Contents, Index and Find.  

· If you select either the BusinessObjects User Guide or Getting Started options, the original BusinessObjects documents are displayed (in Adobe Acrobat pdf format).  

· If you select the Quick Tour option, you will start up a multimedia cbt session which provides a very limited but interesting introduction to Version 5i.

Outside of the BusinessObjects package, the CIS web pages contain a lot of BusinessObjects information, particularly about the available universes.  See http://www.liv.ac.uk/cis/



2
Overview of BusinessObjects 5i

The Main Features

· Creation, execution and management of your own reports using information from the corporate databases.

· Execution of reports that have been pre–defined and distributed by the Computing Services Department.

· Presenting information as simple business charts or graphs.

· Exporting data to other applications such as Microsoft Office.

Universes 
The concept of a universe is central to BusinessObjects. A universe is a meaningful, user–orientated representation of a relational database. In practice, there are several universes, which have been designed by the Computing Services Department to provide particular views of the University’s corporate database. For example, the PERSONNL universe deals with staffing information, the Spider - General universe makes available information from the SPIDER system about students, programmes of study, faculties, etc.  New universes will be created or existing universes will be enhanced by the Computing Services Department as part of the on-going development of the service. 

When you look at the list of available universes, you will also find a number of demonstration universes - Island Resort Marketing, Car Lease and eFashion. These are installed with the BusinessObjects software and are used to provide examples in the online BusinessObjects documentation.

Objects 

Each universe is constructed with a set of objects. An object is an item of information that is of interest to a user of the information. It corresponds to a selection of data from the database and is, most usually, a column in a database table. For example, the following objects can be found in the Spider - General universe: Program Faculty Code, Program Code, and Program Level Code. 

Classes 

Within a universe, you will find objects grouped together into classes. When the Computing Services Department designs a universe, it groups objects into classes, solely, to reflect the user’s natural grouping of items of information. In turn, some classes contain sub-classes.  The purpose of classes and sub-classes is to make it easier for you to locate and select the objects you want when building a report. They play no other part in retrieving information. For example, the Spider - General universe contains a class called Program Data and Curriculum Rules. The objects mention above can all be found in this class.

3
Starting BusinessObjects
Starting BusinessObjects

· To start BusinessObjects, click the BusinessObjects icon (the installation procedure will have placed BusinessObjects icon in the Programs menu).  

· The BusinessObjects User Identification window will pop up asking you to enter your BusinessObjects username and password.  

· Enter your BusinessObjects password (see below). Do not check the Use In Offline Mode option. 

· Click the OK button to proceed.

Username and Password

A BusinessObjects username and password will be allocated to you when you register for BusinessObjects use (see Section 15 Registration page 46).  If you are a user of the CIS facilities you will be allocated the same username for BusinessObjects.  However, you will be given a BusinessObjects password that is different from any existing CIS service password. You can change your BusinessObjects password at will by using the Change Password command on the Tools menu.

New Report Wizard

When you have successfully logged on, the BusinessObjects window is displayed and the New Report Wizard is started, as shown in Figure 1. We will discuss the New report Wizard in some detail in Section 4, Creating a New Report.  If you do not want to create a new report, click the Cancel button to end the New Report Wizard. 
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Figure 1: New Report Wizard

4 Creating a New Report 

In this section, we will look at how the New Report Wizard is used to create a report.  For this purpose we will work through a simple example. We must start, however, by considering the distinction that BusinessObjects makes between reports and documents.

Reports and Documents

The term document has a particular meaning in BusinessObjects. A BusinessObjects document is a file that contains a report. In fact, as we will see later, it is possible for one document to contain many reports. BusinessObjects stores documents on your computer as files. By default, it stores the files in your UserDocs folder. The files are given a default file extension of .rep. For instance, if you were to build a report called Course List, it would be stored on your computer in a BusinessObjects document with the following path and filename:

C:\Business Objects\BusinessObjects 5.0\UserDocs\Course List.rep 

A Worked Example

Throughout this section we will refer to a simple example to illustrate a variety of points. The example report uses the Spider - General universe to produce a course list, i.e. a list of the programmes of study within each faculty (see Figure 2). The Course List will show the faculty, the programme code, a description of the programme and the programme level (undergraduate, taught postgraduate etc.) All programmes are listed and they are listed in no particular order. In later sections of this document we will enhance the Course List report to illustrate further features of BusinessObjects, including selecting the information to be reported sorting it into a meaningful order.
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Figure 2: Course List example report

Starting the New Report Wizard 

BusinessObjects 5i helps you to create a new report with the New Report Wizard.  The New Report Wizard starts automatically, by default, when you log into BusinessObjects.  

· To start the New Report Wizard at any other time select the New option from the File menu.

Using the New Report Wizard 

The wizard creates a new report in 4 easy stages.

Stage 1:  you decide on the layout that you want the report to have. You can generate a standard report, or select a template. A standard report contains predefined styles (e.g. font and colours) and displays the data in a simple tabular format. On the other hand, selecting a template enables you to build a report in a more complex structure. You are recommended to opt for a standard report. As we will see later, you can enhance a standard report in a whole variety of ways.

Stage 2:  you specify the type of  data provider you want to use. The data provider is the mechanism that retrieves data from the database or file. The most common type of data provider that you can use is a query on a universe. Advanced users may choose other types of data provider, i.e. stored procedures, Visual Basic procedures or personal data files.

Stage 3:  you select the universe with which you want to work.

Stage 4:  you build the query (or other type of data provider). Building a query is done in the Query Panel where you can select the objects you want to see in your report. The objects come from the universe that you have selected. 

The decision points at each stage in the New Report Wizard are presented to you in dialogue boxes. These are described in the rest of this section.

Stage 1: Standard Report or Template?

By default, the option to Generate a standard report is selected in the New Report Wizard’s first dialogue box (as in Figure 1). 

· If you want a standard report, click the Next button — this will take you to the Data Access dialogue box. The example Course List report is created as a standard report. This is the recommended option.

· If you want to use a template for the new report, click the Select a template option — this will pop up the Select a Template dialogue box, as in Figure 3. 

· In this dialogue box, click an available template to select it, then click the Next button — this will take you to the Data Access dialogue box. 
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Figure 3: Select a Template dialogue box

Stage 2: Selecting a Data Provider 

In the Data Access dialogue box (see Figure 4) you select the way you want to access data for your report.  Here we describe how to access data with a query on a universe.  The other types of data provider, which can be selected from the pull-down list, are used very rarely.

· The first stage in building a query, therefore, is to click the Universe option. 

· Then, click the Next button  — this takes you to the Select a Universe dialogue box. 
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Figure 4: Data Access dialogue box

Stage 3: Selecting a Universe

In the Select a Universe dialogue box (see Figure 5) you see a list of universes to which you have been granted access. 

· Click the universe you wish to use — if necessary, scroll down the list to find the Universe you want. In our example, the Course List report is based on the Spider - General  universe.  

· Click the Finish button — the Select a Universe dialogue box ends and the Query Panel appears.
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Figure 5: Select a Universe dialogue box

Stage 4: Building a Query

The final step in creating a report based on a universe is to build the query. Building a query to provide the data for you report is done using the Query Panel. The Query Panel is described in Section 5, Using the Query Panel.

5 Using The Query Panel

[image: image11.png]


The Query Panel is a graphical interface that enables you to build a new query. It is also used to edit an existing query. The Query Panel is illustrated in Figure 6 and shows the query needed to produce the Course List report. Here we will introduce only the main features of the Query Panel. For a complete description of all the functions, use the Help button on the Query Panel toolbar.  
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Figure 6: the Query Panel

Displaying the Query Panel
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When you create a new report using the New Report Wizard, the Query Panel is displayed as the final window in the dialogue. Alternatively, if you want to edit the data provider for an existing report, you can display the Query Panel as follows: 

· Either click the Edit Data Provider button on the standard toolbar or select the Edit option from the Data menu.

Classes and Objects Box
The Classes and Objects box in the Query Panel presents the classes, sub-classes and objects of the universe that you are using.  A class is a logical grouping of objects and is represented by a folder icon. Classes can also contain sub–classes, as folders can contain sub–folders. When the Query Panel is first displayed, only the universe’s classes are visible. 

· Click the + plus to the left of a class icon to open the class and view its sub–classes and objects.  Click the + plus to the left of a sub-class icon to open the sub-class. You will see in Figure 6 that the Program Data and Curriculum Rules class has been opened to reveal its objects. 

Alongside each object name is an icon that indicates the type of object. An object will be one of three types: dimension, detail or measure.  
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The cube icon indicates a dimension object. Dimension objects retrieve the data that will provide the basis for analysis in a report and typically retrieve character type data (e.g. the Program Code object in the Spider - General universe). 
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Some dimension objects have an associated detail object. The detail object provides more detailed information about the dimension. For example, CAPP Program Description is the detail object associated with Program Code.  A detail object is represented by the pyramid icon and can be revealed by clicking the + plus to the left of the dimension. 
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The sphere icon indicates a measure object. Measure objects retrieve numeric data that is usually the result of calculations on data in the database. As such, measure objects are semantically dynamic — the values they return depend on the dimension objects with which they are grouped in a particular query. 

Query Results Box
Including Objects in a Query

When you include an object in the query, you instruct BusinessObjects to retrieve the data for that object from the database. For example, to display the Program Faculty Description, Program Level Description, Program Code and CAPP Program Description information in the Course List report you include those objects in your query. 

You include an object in a query by placing it in the Query Results box. In Figure 6, the Query Results box contains those objects needed to produce the Course List report. There are three ways of placing objects into the Query Results box. You can: 

· Double–click an object in the Classes and Objects list.

· Click an icon in the Classes and Objects list, and drag it to the Query Results box.

· Click a class folder and drag it to the Query Results box. All the objects in the class appear in the Query Results box.

Once you have included the required objects in the Query Results box, you have built a basic query that could be run to retrieve the data from the database. If you wish to try this now, you can jump ahead to Executing a Query from the Query Panel page 12.

Removing Objects from a Query

If you decide you want to remove an object that you have previously included in your query, select the object in the Query Results box by clicking its icon. You can now remove the object in any of the following ways:

· Drag the icon to the Classes and Objects list.

· Press the Delete key.

· Click your right mouse button — a popup menu appears.  Select the Remove command on the popup menu.
Changing the Order of the Objects 

The order in which the objects appear from left to right across the Query Results box determines the order in which the data will appear from left to right across your report. To move an object, click its icon. You can now:

· Drag the icon to the left or the right, then release the mouse button.

· Swap the icon with another object icon in the Query Results box, by holding down the Shift key, dragging it until it is above the object you want to swap, then releasing your mouse button.

Conditions Box
This box on the Query Panel displays any conditions that are built into the query. A basic query, such as the query used for the Course List report, has no conditions and does not use the Conditions box (as shown in Figure 6). In the next section of this document  (see Section 6, Query Conditions) we will discuss how to specify conditions in a query in order to filter out unwanted data from a report. 

Creating Your Own Objects

BusinessObjects allows you to create your own objects that can redefine universe objects in some way or other. The extent of the redefinition can be as simple as re–naming the object, or it can be a sophisticated procedure to perform calculations combining several universe objects, or it may involve the use of  SQL functions to format the data in a particular way. Objects you create are for your use only and do not alter the universe as other users see it. They are listed in the User Objects class in the Classes and Objects box. 
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To create or edit a user object, click the User Objects button on the Query Panel toolbar. The User Objects dialogue box pops up displaying a list of your user objects. 

· To create a new user object, click the Add button. 

· To edit an existing user object, highlight the object in the list, then click the Edit button.  

In both cases the User Object editor window pops up enabling you to build or alter your user object.  

The User Object editor window has two tabs — the Definition tab, which is displayed first, and the Formula tab. 

· For detailed instructions on how to build a user object, click the Help button on each tab in the User Object editor window or see User Object in BusinessObjects Help/Index.

Executing a Query from the Query Panel

You can execute your query from within the Query Panel. If you have just built a new query or modified an existing query, this method is convenient.  

· To execute the query, click the Run button on bottom of the Query Panel.  Your report is displayed in a report displayer window.  

Running queries is dealt with in more detail in Section 8, Managing Your Reports.

6 Query Conditions

A basic query, such as the query needed to produce the Course List, contains objects only. A basic query retrieves all the data from the database for those objects. For that reason, such a basic query is sometimes called an open query. Whilst open queries have their uses, you would normally want to filter out unnecessary data or limit your query results to the data that you particularly need. In a query, searching for particular data or filtering out unwanted data is achieved by the use of conditions.  In this section, we describe how to use the Query Panel to apply your own simple conditions. We will continue to work through the Course List example, and build a condition into the query in order to restrict the list to courses in particular faculties.  
Applying Your Own Simple Condition

A simple condition is a condition based on an object that you have included in your query.  So, to specify a simple condition you, first, click the object’s icon in the Query Results box in the Query Panel.  Then, click the Simple Condition button on the toolbar.  

For example, to restrict the Course List to courses in the Dentistry and Medicine faculties:

· Click the Program Faculty Description object in the Query Results box.  
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Click the Simple Condition button on the Query Panel toolbar — a list of values for the object is retrieved from the database and is displayed in the List of Values dialogue box. Figure 7 shows the List of Values dialogue box for Program Faculty Description.
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Figure 7: List of Values

· Select the value you want from the list. To select more than one value from the list, hold down the Ctrl key on your keyboard while you click the mouse. For example, to select both Faculty of Medicine and School of Dentistry, click on Faculty of Medicine then hold down the Ctrl key while you click on School of Dentistry — both will be highlighted. (Tip: if the list is very long you can check the selections you have made by clicking the Show Selected Only option.)

· When you have selected the values you want from the List of Values dialogue box, click the OK button — you are returned to the Query Panel. You will notice that the Conditions box is now populated with your condition.

You can place simple restrictions or filters on any number of objects included in your query in order to restrict the data it retrieves. For example, you could further limit the query so that it retrieved only undergraduate courses in Dentistry and Medicine. To do this, you would need to build another condition into the query. The new condition, on the Program Level Description object, would limit the results to records where the Program Level Description  is Undergraduate. 

Applying Complex Conditions 
So far we have discussed simple conditions only — in a simple condition you compare an object to a value or values chosen from a list. Conditions, however, can be far more flexible and powerful. BusinessObjects refers to such conditions as complex but that does not necessarily mean they are any more difficult to build. 

To build complex conditions you use the Conditions box in the Query Panel. There are 3 stages in building a complex query condition:
1. you select the object you want, e.g. Program Faculty Description
2. you select the operator you want, e.g., equal to 

3. you select the type of operand, e.g. a constant value that you type into the condition or a constant value that you select from a list of values.

We do not discuss complex conditions any further in this document. For a full description see Applying Complex Conditions on Queries in the BusinessObjects User Guide (page 91).

Modifying a Condition 

Once you have applied a condition on an object in a query, you can modify it or remove it.

Changing the Values in a Condition

If you want to change the values to be retrieved for a particular object:

· In the Conditions box of the Query Panel, click the value(s) that appear(s) on the right-hand side of the condition. The Classes and Objects box becomes the Operands box and now lists the various types of operand that can be applied.

· Double–click the Show list of values operand. The possible values for the object appear in the List of Values dialogue box (see Figure 7).

· Select the value or values you want from the list as described above in Applying Your Own Simple Condition.

· When you have selected the values you want, click the OK button — you are returned to the Query Panel. You will notice that the Conditions box now shows your modified condition.

Removing a Condition
· To remove a condition, click the condition’s icon in the Conditions box, then press the Delete key.

Groups of Conditions 

Simple or complex conditions may also involve the need to group several conditions together in order to seek out the information you need. This may also require the use of both logical operators —  AND and OR. For more information about grouping conditions see Applying Groups of Conditions in the BusinessObjects User Guide (page 105). 

Pre-defined Conditions
[image: image20.wmf]In any universe there may be predefined conditions that we, in the Computing Services Department, have created to save you time. Where they exist, you can apply one or more of these conditions when you build a query. However, you can neither delete predefined conditions from a universe, nor can you edit their definition.  

To see what predefined conditions exist (if any) click the filter radio button at the bottom of the Classes and Objects box in the Query Panel — this replaces the Classes and Objects box with the Predefined Conditions box. The Predefined Conditions box lists the available conditions grouped into classes, in the same way that objects are grouped into classes. To apply a pre-defined condition:
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Drag the required pre-defined condition into the Conditions box.

· To return to the Classes and Objects box, click the objects radio button at the bottom of the Predefined Conditions box.  

7 Sorting Query Results

You determine the order in which columns of data appear from left to right across your report by the sequence in which you position objects in the Result Objects box in the Query Panel. It is also important to control the order in which data appears down a column in your report. This is achieved by sorting on an object. Sorting can be specified either within or from the Query Panel.

Data Type and Sort Order

The data you retrieve for an object can be text, numbers or dates. You can sort any type of data into ascending or descending order. The following table summarizes the effect of sorting each type of data: 

	
	Text
	Numbers
	Dates

	Ascending Order
	A - Z
	Lowest to Highest
	Past to present

	Descending Order
	Z - A
	Highest to Lowest
	Present to Past


Applying a Sort 
The simplest way to apply a sort is on an object in the Query Results box in the Query Panel. At the same time you also specify the sort order. For example, to list courses in faculty order in the Course List report, an ascending sort on the Program Faculty Description object is required. To apply this:
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Click the Program Faculty Description object in the Query Results box.

· Click the Sort button on the Query Panel toolbar (do not confuse this with the Manage Sorts button, which is described below in Managing Sorts in the Sorts Dialogue Box ). A sort icon appears below the object icon in the Query Results box.

The sort icon shows the default sort order with the A–Z legend, i.e. ascending.  It also shows a number that indicates the sort priority. 

Determining the Order of a Sort

When you apply a sort, BusinessObjects assumes that you want to sort in ascending order. The easiest way to change the order of a sort is to double–click the sort icon in the Query Results box. A double–click toggles between ascending and descending order. The legend on the sort icon shows A-Z or Z-A to indicate the order of the sort. 

Sort Priority

When sorting on multiple objects the priority of objects is important. Priority is determined simply by the sequence in which you apply sorts to objects in the Query Results box and is indicated by the number that appears against each sort icon. For example, the Course List report would be more meaningful if it were sorted, as follows: (1) Program Faculty Description, (2) Program Level Description, (3) Program Code.

Removing a Sort
There are two ways to remove a sort from a query using the Query Panel:

· Click the sort icon under the object in the Query Results box and press the Delete key.

· Drag the sort icon from the object in the Query Results box, to the Classes and Objects list, where you release your mouse button.

In both cases, the sort icon disappears from the object in the Query Results box.

Managing Sorts in the Sorts Dialogue Box
[image: image23.png]8



The sorting functions described above can also be effected in the Sorts dialogue box (see Figure 8). In addition, you use this dialogue box to apply transparent sorts, i.e. sorts on objects that are not included in the query. 

· To display the Sorts dialogue box, click the Manage Sorts button on the Query Panel toolbar. 
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For detailed information on using the Sorts dialogue box, click the Help button on the dialogue box.

Figure 8: Sorts dialogue box
8 Managing Your Reports

In this section we will consider various aspects of managing your reports, in particular:

· Saving a report in a document

· Opening documents and reports

· Refreshing the data in a report 

Saving the Report Inside Its Document

[image: image25.wmf]As we saw earlier, reports are saved inside documents (see Section 4, Reports and Documents, page 5). When you create a new report using the New Report Wizard, BusinessObjects also creates a new document. To save the document: 

· Click the Save button on the Standard toolbar, or select the Save command on the File menu. 

The Save Document As dialogue box appears. By default, the UserDocs folder on your computer is active and the default file name is Documentn (where n is a number allocated sequentially by BusinessObjects).

· It is recommended that you type a different name in the File Name box — something meaningful to you and/or your colleagues, e.g. Course List.

· Click Save. The Save Document As dialogue box closes although your report remains open. The name you gave the document now appears in the title bar of the BusinessObjects application window. 

The default file extension for BusinessObjects documents is .rep and the default folder is your UserDocs folder. Normally, you should not change these defaults.  However, there are circumstances where you may want to save documents in folders other than the UserDocs folder, and with file extensions other than .rep. For example, you can save a document with the .htm extension, which enables you to post it on a web server. For more information about saving documents, see Saving a Document in the BusinessObjects online help.

How the Data is Stored in the Document

When you save a BusinessObjects document you save the query, the report definitions and also the last set of results you obtained. The structure that stores the query results in the document is known as the microcube. You can think of the microcube as a local database attached to the document. 

Although the microcube stores all the data retrieved by your query, you may choose in your report to ignore some of the objects. Any non–displayed data is, of course, still present in the microcube. This means that you can use that data whenever you like in another report inside the same document. This feature is particularly useful when you want to analyze a set of data: you can analyze the data along different dimensions in different reports, each one displaying only the data that is pertinent for your analysis. Analysing data is described in Section 10 Analysing Data  page 32.

Opening an Existing Document and Report

The simplest way to open a recent document is to select it from the recent file list on the File menu. This displays up to nine recently used files (you can set the actual number in Tools | Options | General). Alternatively, you can open any of your documents as follows:
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Either select the Open command from the File menu or click the Open button on the standard toolbar. The Open a Document dialogue box appears (see Figure 9).

· Using the Open a Document dialogue box, navigate to the required folder - the UserDocs folder is the default display. 

· Click the document you require. It is highlighted. Then click the Open button.  

· The report displayer window is opened. Each report in your document is shown as a tab. The first report is open by default. To open a different report within the document, click the appropriate tab. 
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Figure 9: Open a Document dialogue box

Changing the Name of a Report

BusinessObjects automatically names the reports within your document i.e. Report1, Report2 etc. When you have a document that contains several reports you will find it useful to rename the reports with something more meaningful. You rename a report using the Rename Report dialogue box.  To display this box:

· Double–click the Report tab

· or right click the Report tab and select Rename from the pop up menu

· or select the Report>Rename option from the Format menu.

Refreshing an Existing Report

There are several ways that you can refresh the data associated with a report, i.e. to run your query again and obtain the latest set of results from the database:

· Use the Refresh command.

· Use the Data Manager.

· Use the Query Panel.

· Automatically on opening the document.

· Using the Broadcast Agent to schedule the processing 

We will consider each of these procedures in the rest of this section.

Using the Refresh Command to Refresh a Report

· [image: image27.png]


Open the document. 

· Click the Refresh button on the standard toolbar. This is the same as  selecting the Refresh option from the Data menu.

Using the Data Manager to Refresh a Report

The Data Manager is used for various functions one of which is to refresh query results.  To refresh results using the Data manager:

· [image: image28.wmf]Open the document.

· Select the View Data command on the Data menu or click the View Data button on the standard toolbar — the Data Manager window is displayed (see Figure 10). 

· In the Data Providers box of the Data Manager window, click the icon of the query that you want to run.

· Click the Refresh button in the Data Manager window.

For more information about using various functions of the Data Manager, e.g. refreshing your results at regular intervals, click the Help button in the Data Manager window.

Using the Query Panel to Execute a Query

You can execute a query from within the Query Panel. If you have just built a new query or modified an existing query, this method is very convenient. 

· To execute the query, click the Run button on bottom of the Query Panel.  
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Figure 10: the Data Manager

Refresh a Report on Opening a Document

To automatically refresh the data whenever you open a document, you need to set a BusinessObjects option, as follows:

· Select the Options command on the Tools menu — this pops up the Options dialogue box.

· Click the Save tab on the Options dialogue box.

· Check the Refresh Document when Opening option on the Save tab. The option is set for the current document only.

Scheduled Processing

BusinessObjects enables you to submit a document for execution at a specified time and date. This is sometimes called batch processing.  In BusinessObjects Version 5i, batch processing is one of the functions of Broadcast Agent.  Broadcast Agent is described later in Broadcast Agent page 38.

9 Reports - Formats and Structures

In this document, the term formatting refers to the way text is displayed in a report - what font style is used, the font size, the colour, the font alignment etc.  Structure refers to the positioning of data in a report - e.g. is your report data structured as a table or is it structured as a crosstab?  The best way to learn about formatting and structuring is to allow the New Report wizard to generate a standard, tabular report. Then, using the numerous different formats and structures that are available, modify the basic report until it matches your requirements.

Format Commands

Data in a report is displayed in cells. Formatting attributes apply to individual cells. So any data appearing in a report is displayed with the format attributes of the cell in which it is located. A report is initially displayed using the default formats. To change the formats, the general procedure is to click the cell that you want to format - you can also select a range of cells. Then, apply the required format command. 

The commands can be found in the Format menu. Shortcuts to many of the Format menu commands are also available on a number of toolbars that are available. These are not automatically displayed in your BusinessObjects window. To display any or all of the toolbars:

· Pull down the View menu.

· Select the Toolbars option from the View menu. This pops up the Toolbars dialogue box showing which toolbars are available and which are displayed.

· Click the required options. The toolbars are displayed and stay in your BusinessObjects window from now on.

For more information about the format commands which appear in the Format menu click the Help button on the Format Cell window. 

Master/Detail Reports

An important alternative to the standard tabular structure is the master/detail structure. An example Master/Detail report is illustrated in Figure 11. This shows the Course List data presented as a Master/detail report. 

Master/detail reports break down the overall report into sections. Each section is headed by a different value of the master object — in the example, the Program Faculty Description is the master object, so there is a section for "Continuing Education" and another section for "Education and Extension Studies" etc. The data in each section provides the detail for the master value — in the example, each section lists the courses for each Faculty. The detail illustrated in the example is structured as a table. However, as we will see later, the detail can also be shown as a crosstab or as a chart. 

[image: image30.png]


[image: image31.png]


[image: image32.wmf][image: image33.png]


[image: image34.png]


[image: image35.png]Create a New Report

[ —
ety i it e o

Pt gt o
© G it

[ re—

ik et sy o s




[image: image36.emf][image: image37.emf]
[image: image38.emf][image: image39.emf]
Figure 11: Master/detail report 

Building a Master/Detail Report
It is easy to structure an existing, table report as a master/detail report. For example, the following steps will transform the structure of the Course List report from a simple table to a master/detail, as illustrated in Figure 11:

· Open the report.
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Click inside the column or row that contains the data you want to use as master — the cell is highlighted. In the example, click in the Program Faculty Description column to highlight it. 

· Click the Set as Master button on the Report toolbar or select the Set as Master option from the Format menu (this option is also available on the popup menu that appears when you click your right mouse button). The column or row of data that you highlighted is removed from the table or crosstab. For each value of that object, a section is created.  Each section contains:

· A master cell that displays one value, e.g  Program Faculty Description.

· A table containing the related detail.

Multi Master/Detail Reports
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[image: image47.emf]Figure 12 illustrates the Course List structured as a multi master/detail report. You can see that the Course List report now has two masters — the top level master is the Faculty Description and, beneath that, the second master is the Program Level. For example, figure 12 shows the Dentistry courses, firstly, at Postgraduate (Research) level, secondly, at Postgraduate (Taught) level and, finally, at Undergraduate level.
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Figure 12: Multi  master/detail report

A multi master/detail report that has 2 levels of master is structured into 2 section levels. The first section level contains only the values of the first level master. The second section contains the second level master values as well as the related detail. The second section is repeated for each value reported for the top level master.

Building a Multi Master/Detail Report

To transform the Course List master/detail report (as illustrated in Figure 11) into a multi master/detail report (as shown in Figure 12):

· Open the master/detail report.

· Click inside the column or row in the table that contains the data you want to use as the second master. For example, if the existing master is Program Faculty Description, click Program Level Description to make that object the second master. The Program Level Description column is highlighted. 

· Click the Set as Master button on the Report toolbar, or select the Set as Master option from the Format menu. This option is also available on the popup menu that appears when you click your right mouse button. The column or row of data you clicked is removed from the table or crosstab, for example Program Level Description is removed from the detail table. For each of its values, a second master cell is created inside a new section that also contains the related detail. For example, Program Level Description now occupies the second master cell in a new section that also contains the table of course codes and course names. 

Formatting Report Sections

The simplest way to re–structure a master/detail report is to use the Slice and Dice Panel. Using a drag and drop technique, the Slice and Dice Panel enables you to re–organise the layout of objects in your report, including changing the master object(s).  The Slice and Dice Panel is discussed in more detail later in this document (see Slice and Dice page 32).

To control the horizontal and vertical behaviour of the master/detail report, such as inserting page breaks or to shade sections of the report, you can use the Section Format dialogue box:

· Click inside the section of the master/detail report that you want to change — this selects the section on which you want to work. In the report displayer window, the section is delineated and the section name is shown

· Select the Section command from the Format menu, or the Format Section command from the popup menu (right mouse click). The Section Format dialogue box appears.

· For more information about using the Section Format dialogue box, click the Help button inside the dialogue box.

Crosstab Reports

In a crosstab report, data is displayed in a matrix. The rows and columns of the matrix represent dimension objects. The cells of the matrix, which BusinessObjects refers to collectively as the body, are populated by measure objects.  In a report, these measures are dynamically related to the values of the row and column objects. For example, Figure 13 illustrates a simple crosstab report. The body of the report shows the numbers of registered undergraduate students in Medicine.  The rows show the various values for the Student Type Code (i.e. the programme year). The columns show the various values of the Student Program Code. The values for Person Count are related to both the year and the course and provide the body of the report.
Inserting Crosstabs into Reports

The New Report Wizard will create a new report with a crosstab structure if you select the appropriate template (see Standard Report or Template? page 6).  However, there is another wizard, the New Crosstab Wizard, which enables you to insert a crosstab into an existing report or to insert a new crosstab report into an existing document. In the crosstab you can display existing data from the document or you can bring new data to the document by building a new query or other data provider. 

 

  

Figure 13: Crosstab report

Using the New Crosstab Wizard

Here we will describe the procedure to insert a crosstab into a report using existing data from the document. If you want to work your way through this procedure using the above report as an online example, you will first need to retrieve the report, spi_Example_Crosstab, from the repository.  (If you are unsure about retrieving documents from the repository, refer to Section 12, Retrieving Corporate Documents page 42).  

· Open the report, e.g. the spi_Example_Crosstab Report.

· Click inside the report in a blank space.

· Click the Insert Crosstab icon on the Report toolbar or select the Crosstab command on the Insert menu. The cursor changes to a cross–hair.

· Click in a blank part of the report and hold down your mouse button. Drag the cross–hair to draw a rectangle where you want the crosstab to appear. A fine gray border appears around the area you have drawn. When you release your mouse button, the New Crosstab wizard is activated.

· In the first dialogue box in the New Crosstab Wizard, select the Use existing data from the document option and click the Begin button.

· The next dialog box (see Figure 14) is used to select the variables (objects) you want to see in your crosstab. Hold down the Ctrl key and click the variables whose data you want to display, e.g. Student Program Code, Student Type Code, Person Count.


· Click the Next button.

· The final dialogue box, Pivot Data for the Crosstab, is shown in Figure 15.  When the dialogue box is first displayed BusinessObjects will have structured your crosstab for you. Here, you can change the structure; you can pivot or rotate your crosstab by switching the dimension objects (variables) from columns to rows or vice versa.  

  
· In the Pivot Data dialogue box, the columns, rows and body are depicted as folders. You move a variable in the appropriate folder by simple drag and drop. When you are happy with the structure, click the Finish button. 

For example, to produce the Example Crosstab report, there should be one column — Student Program Code.  There should be one row — Student Type Code.  Person Count should form the body of the crosstab.

Changing the Structure of a Crosstab Report

As with the master/detail report, the simplest way to re-structure an existing crosstab report is to use the Slice and Dice Panel. Using a drag and drop technique, the Slice and Dice Panel enables you to re–organise the layout of objects in your report, such as moving the variables in the row(s) and column(s). The Slice and Dice Panel is discussed in more detail later in this document (see Slice and Dice page 32).

Charts and Graphs

You can insert a chart or graph in a report. In the chart you can display existing data from the document. So, for example, your report could display the same set of data in a table and also in a graphical form. BusinessObjects provides a wizard to facilitate the creation of  Charts - the New Chart Wizard.

Using the New Chart Wizard

The procedure to insert a chart in a report, using existing data from the document, is briefly described below:

· Click inside a blank space in the report.

· Click the Insert Chart button on the Report toolbar or select the Chart option from the Insert menu.  The cursor changes to a cross–hair.

· Click in a blank part of the report and hold down your mouse button. Drag the cross–hair to draw the area where the new chart will appear. A fine gray border appears around the rectangle you have drawn. When you release your mouse button, the New Chart wizard is activated (see Figure 16).
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Figure 16: New Chart Wizard
· In the wizard dialogue box, click the first option, Use existing data from the document, then click the Begin button. 

· The next step is to specify the data that you want to display in the new chart.  A list of variables, i.e. the objects selected in your query, is popped up inside the dialogue box. Hold down the Ctrl key and click the variables that you want to display.

· You must now specify the chart style you want:

· To generate a default chart, which displays the selected variables in the most logical chart style, check the Generate a default chart option which is now displayed in the dialogue box. The Next button becomes the Finish button.  

· Click the Finish button to display the chart in the area you drew. 

· To select a chart type and style, leave the Generate a default chart option unchecked and click the Next button. The Chart AutoFormat dialogue box appears (see Figure 17). The Chart AutoFormat dialogue box displays a list of available chart types. 

· Click a chart type to select it — the appropriate styles are displayed as icons alongside.  Click a style to select it.  

· Click the Finish button to display the chart in the area you drew.
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Figure 17: Chart Auto format dialogue box
Using the Report Manager Window

Report Manager enables you to manage various aspects of your report - you can control all the variables in your report, work on the structure and formatting of report components and navigate from section to section or report to report.

To open the Report Manager window:

· Either click the Report Manager icon on the standard toolbar

· Or select Report Manager option from the View menu.

· When the Report Manager window opens, it is docked on the left-hand side of your report window. If you wish, you can undock the Report Manager window and drag it to any other convenient location on your screen. Hold down the Ctrl key while moving the Report Manager window to prevent it from docking.

Report Manager Data Tab

The Data tab is used to manage the variables in your report. It contains a list of the variables and formulas in your document. You can drag variables from this list and drop them directly into the report window to construct or edit tables and other components. You can also create new variables or edit existing variables.

You can bring new data into your report directly from the Report Manager window. You can edit the current query or set up another one. Simply right-click on a folder or variable and choose the appropriate option from the menu.

You can view the list in two different ways by clicking the appropriate radio control button at the foot of the Report Manager Window:

· In alphabetical order: in this view, all the variables in the document are listed in alphabetical order with the variables in the Variables folder and the formulas in the Formulas folder.

· By query: in this view the variables are grouped into the queries from which they were returned.

Report Manager Map Tab

The Map tab is used to manage the structure of your document. Two views of the structure are available in the Map tab. You can toggle the two views by clicking the appropriate radio control button at the foot of the Report Manager Window:

· Navigation View: displays a list of all the reports in the BusinessObjects document. For the report currently displayed on your screen the section names are also displayed. You use this view to go from report to report and from section to section within a report.

· Structure View: displays a list of all the components in the selected report. Each report component (header, section, cell, table, chart etc.) is represented by an icon and a name. The name of components hidden in the report are displayed in italics.  When you click on an icon in the Report Manager window, the corresponding component is displayed in the main report window. You can rearrange the components in the report by dragging and dropping them from one position to another in this list. You can also work on the formatting of the different report components and on breaks, sorts and filters. Right-click on an icon in the list and choose the appropriate option from the menu.

Building Reports: Further Information
In the BusinessObjects User Guide  there are various chapters dealing with reports.  The following, in particular, are recommended:-

Chapter 9 Report Basics and Report Manager

Chapter 10 Displaying Data in Tables

Chapter 11 Master/Detail Reports

Chapter 12 Organizing Data in Reports

Chapter 17 Creating Charts

Chapter 18 Formatting Charts
10 Analysing Data - Slice-and-Dice

Analysis Techniques

In BusinessObjects you can analyse the data you have retrieved with your query by looking at it from different viewpoints and on different levels of detail. Because of the way the data is stored in its own microcube (see Section 8, How the Data is Stored in the Document page 18) this kind of analysis is very quick — much quicker than building and running another report. Two multi–dimensional analysis techniques can be used:

· Slice-and-dice 

· Drilling

In this section we will discuss some of the basic features of working in slice–and–dice mode.  Drilling is discussed in detail in Section 11, Analysing Data - Drilling.

Slice and Dice

 Slice–and–dice, sometimes referred to as rotation, enables you to easily switch the position of data in a report. For example, in a crosstab report, you can very easily move data from columns to rows and vice versa. Slice–and–dice operations are carried out using the Slice and Dice Panel (see Figure 18). This popup window provides a graphical representation of the structure of the report you are working on.  Different icons represent the data you can use. You can structure your report by dragging and dropping the icons into the position you want. 

Figure 18: Slice and Dice Panel

The Slice and Dice Panel

To display the Slice and Dice Panel, select the Slice and Dice command on the Analysis menu, or click the Slice and Dice button on the Standard toolbar. 

In the Slice and Dice Panel you can:

· Build or re–organize the structure of reports.

· Display previously undisplayed data.

· Remove data from the report. 

Section Box

The Section box in the Slice and Dice Panel is used by Master/Detail reports. If the section box is not displayed in the Slice and Dice Panel, click the Show/Hide Section button on the Slice and Dice Panel toolbar to display it. If you drop the icon of an object into the Section box, that object becomes a master. Thus, you could use the Slice and Dice Panel to structure an existing tabular report as a Master/Detail report, as follows: 

· You can use an object that is already displayed in the report. To do this, drag an icon from the Block Structure box, drop it in the Section box. 

· You can also use data that is not yet displayed in the report. To do this, drag an icon from the Available Variables list, drop it in the Section box.

In a similar way you can add new masters, say, to create a multi master/detail report. You can also remove a master to change a Master/Detail report to a standard, table report. To remove a master: 

· Click the icon of the master in the Section box to select it.

· Press the Delete key, the icon is removed from the Section box.

· Once you are happy with master object(s) shown in the Section box, click the Apply button. Your report will be re–drawn, although the Slice and Dice Panel will remain displayed on top. 

Block Structure Box

The Block Structure box in the Slice and Dice Panel shows an icon for each object that appears in a table, crosstab or chart. These icons can be moved, by drag and drop, to reposition them in your report. Objects can be added or removed to or from a block structure in the same way as they can in the Section box.

The Block Structure box is particularly useful for manipulating crosstab reports — the matrix structure is indicated by horizontal and vertical dotted lines. Icons shown above the dotted line signify objects used to provide the row or X axis values in the crosstab. Icons below left signify the objects that provide the column or Y axis values of the crosstab. Icons below right signify the objects that appear in the body of the crosstab. For example, in Figure 18 the Block Structure box shows the structure that underlies the crosstab report shown in Figure 13. The Student Type Code object provides the values for the row while the Student Program Code object provides the values for the column of the crosstab. The values displayed in the body of the crosstab are signified in the Block Structure box by the Person Count icon. 

More Information about Slice and Dice

For more information on using the Slice and Dice Panel to analyse your data, see Slice–and–Dice Panel in Business Objects Help.

11 Analysing Data - Drilling

Drilling is a decidedly interactive technique that enables you to analyse the data in your report on different levels of detail. Drilling down means displaying progressively more detailed data. Drilling up means you display data at a less detailed level. Drilling up and drilling down are possible because your data is structured into a hierarchy.

Drilling is best illustrated by trying it for yourself online. If you are interested in working in drill mode, an example report suitable for drilling can be retrieved from the repository. If you are unsure about retrieving a document from the repository, the procedure is discussed a little later in this document — refer to Section 12, Retrieving Documents from the Repository page 42.

The Drill Example

The spi_Example_Drill_Down document contains one report, Reg Stats. When you open the report it simply shows the numbers of students registered in each academic year (term code) since 1991-92. 

· To enter drill mode, click the Drill icon on the standard toolbar or select the Drill option from the Analysis menu.  

This will open a new report, Reg Stats (1), with its own separate tab. You will use this new report for drilling.  The magnifying glass icon in the report tab indicates you are in drill mode. 

You can drill down using the hierarchy that has been built into this report.  A text note in the document itself outlines the hierarchy. 

Drilling Down 

Say, for example, your attention is drawn to the number of students registered in year 1999-2000, drilling down to the first level of detail enables you to find out the numbers of students in each Faculty. To do that:

· Place your mouse pointer on the particular value in question, year 199900. Your mouse pointer changes to a magnifying glass containing a plus (+) sign. This signifies that you can drill down. A tooltip will indicate the dimension object that is down one level  in the hierarchy, in this example the next level down is Student Faculty Code.

· To drill down, double–click your mouse. Alternatively, right click the mouse to display a pop up menu, then, select the Drill Down option. Two things happen. Firstly, the table in the report changes to show a faculty breakdown of the total number of students registered in year 1999-2000. Secondly, the Drill toolbar is displayed.

· The selected value, year 199900 in our example, is placed into the Drill toolbar. Each time you drill down, the value on which you have drilled is moved to the Drill toolbar and the data in the table is filtered accordingly. You can examine any of the values for these dimension objects by clicking the down arrow to the right of the value in the Drill toolbar. This drags down a list from which you can select a new value. The related table will change automatically. 

· You can continue drilling down in this way until the plus (+) changes to a minus (-) sign in your magnifying glass. This indicates that you have reached the lowest level in the hierarchy and you can drill down no further.

Drilling Up 

Drilling up takes you back to a less detailed level of analysis, e.g. you could look at the number of students on a given programme, then, drill up to find the total number in the Faculty:

· Place your mouse pointer on a particular value of a dimension object. 

· If the magnifying glass is showing a minus (-) sign, then, the tool tip will indicate the next level up in the hierarchy. To drill up, double–click your mouse 

· Alternatively, right click the mouse to display a pop up menu, then, select the Drill Up option.  

· As you drill up through each level in the hierarchy, the appropriate dimension objects disappear from the Drill toolbar.

Drill By

Drill By allows you to go straight to a particular level in the hierarchy without having to visit each level in turn:

· Place your mouse pointer on a particular value of a dimension object. 

· Right click the mouse to display the pop up menu, then, select the Drill By option.  

· This pops up a list of the dimension objects in the hierarchy. Select the dimension you want. You are immediately taken to that level.

Hierarchies 

In the spi_Example_Drill_Down report the dimension objects that provide the different levels of analysis are structured in the Student Data Hierarchy. This hierarchy was built into the report. If you want to create a report that enables drilling you will need to consider how your dimension objects are positioned hierarchically. You can use the default hierarchy that is implied from the structure of the universe you are using but it is more likely that you will want to build your own hierarchy. You do this with the Hierarchy Editor:

· To start the Hierarchy Editor, select the Hierarchies option from the Analysis menu. This allows you to create your own hierarchy or amend the default hierarchy as appropriate. For detailed information about its use, click the Help button in the Hierarchy Editor window

Drill Through 

If the lowest level of detail you need is not currently available in the report, you can drill through to the database directly and get the data you need. You do not have to edit the query in the Query Panel.

· Place your mouse pointer on a particular value of a dimension object and right click the mouse to display the pop up menu.  

· From the pop up menu select the Drill Through option. The Drill Through dialogue box pops up. Here you can select a dimension that you can drill across. 

· The Help button in this dialogue box provides detailed instructions about its use.

Snapshots

You may want to keep track of the different levels of analysis that you reveal as you drill into your data. You can do this by taking a snapshot of the report at any stage. When you take a snapshot, BusinessObjects creates a copy of the report in a new tab inside the document.

· To take a snapshot, select the Snapshot option on the Analysis menu.

More Information about Drilling

For more information about analysing your data by drilling, see Chapter 20, Analysing Data in Drill Mode, in BusinessObjects User Guide.

12 Broadcast Agent

The Functions of Broadcast Agent
Broadcast Agent is used to perform the following functions: 

· Scheduled Processing (batch processing) — you can refresh a document at a specified date/time. This can be either a one–off process or a process to be repeated at the same time every day, week, month etc.

· Send processed document to yourself, other users or groups of users.

· Print the reports in the document.

· Send the document to the PC Web server. Broadcast Agent saves the document in Hypertext Markup Language (HTML) format, then posts it to the PC Web server.

We will consider the top two functions from this list in detail in this section of the document. For more information about the other functions, click the Help button on the Broadcast Agent window.

Advantages of Scheduled Processing

Scheduled processing enables your reports to be executed while leaving BusinessObjects free to get on with other things. Even if you have logged out of BusinessObjects and turned off your computer, the scheduled execution of your reports can still take place. There are several advantages to this way of working. For example, you could schedule a document for execution overnight at some time after other overnight jobs have updated the database. When you log into BusinessObjects next day, your report will have been refreshed and the results will be waiting for you.  The scheduled processing of documents, therefore, can save you time. It can also help reduce traffic on the network by running reports at off–peak times which, of course, benefits everyone.

Using Broadcast Agent for Scheduled Processing
· While the document is open, select the Send To>Broadcast Agent command from the File menu, or click the Send to Broadcast Agent button on the Document Exchange toolbar. This pops up the Send Document To Broadcast Agent Server dialogue box. There are several tabs on the Broadcast Agent dialogue box. 

· Start with the General tab.  On the General tab:-

· Select the BCagent server in the Server list box.

· Leave the Priority as Normal.

· Type in an (optional) identifying title for the document to be used by Broadcast Agent.

· On the Actions tab:-

· Select the appropriate action(s), i.e. Refresh Document 

· Click the Add button

· On the Scheduling tab, click the Change button in order to enter the frequency and the start date/time for the processing.  

· On the Distribution tab, click the Distribute via the Repository option:

· If you want to send a document to other users, click the To button in the Send To box — the Select Users dialogue box pops up.

· In the Select Users dialogue box, hold down the Ctrl key and click the users you want, then click the OK button. You return to the Broadcast Agent window.

· If you click the Add my Name to the List option, your user icon appears in the Send to box.

· Finally, click the OK button. The document is submitted to Broadcast Agent for scheduled processing.  

For more information about these and other Broadcast Agent options, click the Help button on the appropriate tab on the Send Document to Broadcast Agent window. 

Retrieving Processed Documents from Broadcast Agent

Once a document has been processed, Broadcast Agent notifies the users who were nominated when the document was submitted. If you are one of those users, you can now retrieve the processed document. However, to be notified that you have documents to retrieve from Broadcast Agent, you must first set an option in BusinessObjects. 

Retrieving Documents — Option Set Up

· Select the Options command from the Tools menu — this pops up the Options dialogue box. 

· In the General tab of the Options dialogue box, check Notify Document Reception, then click the OK button. From now on, a pop up window will appear when you log into BusinessObjects to notify you that you have documents to retrieve.

Retrieving Documents — Procedure
· You retrieve the document(s) by clicking the Retrieve from Broadcast Agent button on the Document Exchange toolbar, or by selecting the Retrieve From>Broadcast Agent command from the File menu — the Retrieve dialogue box appears.

· In the Retrieve window, highlight the document(s) you want to retrieve by clicking them. Click the Retrieve button.

· Documents are retrieved by default to your UserDocs folder. To specify a different folder, right-click the selected document then select the Retrieve Into command on the popup menu that appears.

For more information about retrieving documents, click the Help button on the Retrieve dialogue box.

13 Exchanging Documents

Sending Documents to Another User
· Select the Send To>User command from the File menu or click the Send To User button on the Document Exchange toolbar. The Send dialogue box appears (see Figure 19).

Figure 19: Send to User dialogue box
· Click the To button. The Select Users dialogue box that appears. Select the users you want to send documents to. Hold down the Ctrl key to select more than one user. When all users are selected, click the ADD button to add the names to the Documents Recipients list.  Then, click OK — you return to the Send dialogue box. The icons of the users you have selected appear in the Send to box.

· Click the Add button to pop up a list of open documents in the Add Documents dialogue box.
· Select the document(s) you want to send, then click OK. You return to the Send dialogue box and the selected document(s) appear(s) in the Documents to Send box.

· If the Add Documents dialogue box did not list the documents you want to send, click the Browse button.

· Select the documents you want to send in the dialogue box that appears, then click the OK button. You return to the Send dialogue box.
· To remove a document from the Documents to Send list, highlight the document and click the Remove button.

· To send the listed document(s), click the Send button.
Retrieving Documents from Another User

To be notified that you have documents to retrieve from another user (or from Broadcast Agent), you must first set the Notify Document Reception option (see Retrieving Documents — Option Set Up, page 39).  Once you have set this option, a pop up window will appear when you log into BusinessObjects to inform you if you have documents to retrieve. To retrieve documents:

· Select the Retrieve From>Users command from the File menu or click the Retrieve From Users button on the Document Exchange toolbar. The Retrieve dialogue box appears listing any documents that have been sent to you.

· Select a document to receive. Hold down the Ctrl key to select more than one document.

· Click the Retrieve button. By default the document is saved in your default directory, i.e. in the folder shown in the Save In box.

Retrieving Corporate Documents from the Repository 

Computing Services Department will make documents such as standard reports available to all users from time to time by placing them in a central repository. If you wish to access such documents you will need to retrieve them from the repository, as follows:

· You retrieve the document(s) by clicking the Retrieve from Corporate Documents button on the Document Exchange toolbar by selecting the Retrieve From> Corporate Documents command from the File menu — the Retrieve dialogue box appears showing a list of documents in the repository (see Figure 20).

· In the Retrieve dialogue box, highlight the document(s) you want to retrieve by clicking it. Then, click the Retrieve button.
· Documents are retrieved by default to your UserDocs folder. To specify a different folder, right-click the selected document then select the Retrieve Into command on the popup menu that appears.

· For more information about using the Retrieve dialogue box, click the Help button.


Figure 20: Retrieve From Corporate Documents dialogue box
14 Exchanging Data with Other Applications

You can use data from BusinessObjects documents in other applications. The data you can use corresponds to the complete set of results obtained by a query or other data provider. You cannot use sub–sets of data, such as blocks, columns etc.

Two methods are recommended. You can copy and paste data using the Windows clipboard and DDE (Dynamic Data Exchange), or you can export data to a file using any one of a number of file formats. We will describe both these procedures here.

Dynamic Data Exchange

Using BusinessObjects data in other applications is enabled by DDE. DDE ensures that the data in the target application is automatically updated if it changes in BusinessObjects. For example, you can paste BusinessObjects data into a Microsoft Excel workbook creating a permanent link to BusinessObjects. When you refresh your BusinessObjects document, the data in your Excel workbook is automatically updated. (Note: you can also paste BusinessObjects data into an application without the DDE link).

Transferring data to other applications is one of the functions of Data Manager. To start the Data Manager:

· Open the report whose data you want to use.

· Select the View command on the Data menu or click the View Data button on the standard toolbar — the Data Manager window is displayed (see Figure 10).

· Click the Export button on the Data Manager window. The Export to External Format dialogue box appears.

· In the Export to External Format dialogue box, click the Copy to DDE option. Click the OK button. The dialogue box closes. The results of the report’s query or other data provider are copied to the clipboard. You can now paste them in the target application.

· In your target application, use the Paste Special facility of the target application to paste the query results. In Microsoft Excel this option is on the Edit menu and when selected will pop up the Excel Paste Special dialogue box. In the dialogue box, click on the Paste Link option. For more information about the Paste Special option, see the appropriate Excel Help text. 

· Alternatively, if you do not wish to maintain a link from the target application back to BusinessObjects, use the Paste option to paste the contents of the clipboard into your document. This is a straightforward copy of query results, charts or reports with no linking.

Exporting Data in Files

You can export data from BusinessObjects as a file. Several different file formats are available, including the following:

· Text format — You can open the text file in many different applications, and on platforms other than Windows (Macintosh, OS/2 or UNIX, for example). Text format includes files with the .asc extension, which means that you can work with the exported data in a previous version of BusinessObjects.

· Spreadsheet format — When you view the exported data in the spreadsheet application (Microsoft Excel and Lotus 1–2–3), each value appears in a separate cell. 

Export to External Format

· With your report open, select the View command on the Data menu or click the View Data button on the standard toolbar — the Data Manager window is displayed (see Figure 10).

· In the list of data providers, select the data provider you want to export, e.g. a query on a universe.

· Click the Export button — the Export to External Format dialog box appears. By default, the settings from the last data export are active. 

· In the Export to External Format dialogue box, click the Export to Local File Format option, then type the file name where you want to save the data.  If you omit a path, BusinessObjects will place your file in the default folder (i.e. UserDocs). Otherwise, you can use the Browse button to select another folder and/or file. 

· Then, use the Format list box to specify the file type. If you want to use the data in Microsoft Word or Excel, select the Microsoft Excel (*.xls) option.  When you select a format, the appropriate file extension is added to the file name.

· Finally, click the OK button. BusinessObjects exports your data to the file which you can then open in your target application.

· For more information about using the Export To External Format function, click the Help button in the dialogue box.

15 Registration

Managed Windows Service

BusinessObjects 5i is available only on the MWS. Therefore, to use it you must be a registered MWS user.  Members of staff can self-register for MWS from any networked PC – see the CSD web about Self-Registration at:  http://www.liv.ac.uk/CSD/pg_staff.html for details.  Alternatively, registration forms for this purpose can be obtained from the Computing Services Helpdesk, Brownlow Hill Building (( 44567 or e–mail helpdesk).

BusinessObjects 5i

Existing users of the CIS service must also be registered to install and use BusinessObjects. Registration is handled by the CSD secretaries:

Claire Riley 
( 43718
e–mail C.Riley

Lynn Deans
( 43719
e–mail L.Deans

Clare Dickinson
( 43717
e–mail clared
Registration for Use of Corporate Information Systems Facilities

If you are not a registered user of the CIS service you may still use BusinessObjects, providing that:

· You are a member of staff.

· You have completed the form Registration for use of Corporate  Information Systems (CIS) facilities.
· Your access is authorised on this form by your Head of Department.

· Where necessary, your access is authorised on this form by the data owner.

The form Registration for use of Corporate Information Systems (CIS) facilities can be obtained online at:

http://www.liv.ac.uk/CSD/helpdesk/registration.html

or from the Computing Services Helpdesk, Brownlow Hill Building    (( 44567 or e–mail helpdesk).

16 Installation

You must install BusinessObjects 5i on your MWS workstation. Beforehand, you must install (or must have already installed) the SQL Net software in order to communicate with the University’s Oracle Database Server and you must also map the application server to your S: drive.

Step 1: Mapping the S: Drive

Your S: drive must be mapped to the Senate application server.  If this mapping has not been already effected, you can do this with a simple install, as follows:

· From the Start Menu, select Install > MIS > S Disk.

Step 2: Installing SQL Net

If you have not already installed SQL Net, then it must be installed, as follows:

· From the Start Menu, select Install > MIS > SQLNET 2.3. 

Step 3: Installing BusinessObjects

The procedure is as follows:

· From the Start Menu, select Install > MIS > BusinessObjects 5i. 
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